Release Information

Introduction

Getting Started

Delphix Engine System Administration

Virtual Database Management with the Delphix Engine

Delphix Modernization Engine

Delphix Compliance Engine

Virtualizing Unstructured Files

Virtualizing Oracle E-Business Suite

Jet Stream

Mission Control Admin User Guide

Delphix Express User Guide

Reference


Documentation for Previous Versions of the Delphix Engine

Delphix Server 3.0 Documentation
Delphix Server 3.1 Documentation
Delphix Engine 3.2 Documentation
Delphix Engine 4.0 Documentation
Delphix Engine 4.1 Documentation

Skip to end of metadata
Go to start of metadata

Welcome to the 4.2 release of the Delphix Engine database virtualization system.      

4.2 Upgrade Matrix

Upgrades to Delphix Engine 4.2 are supported from 4.0.0.0 and above. 

 4.2.0.04.2.0.14.2.0.24.2.0.34.2.1.04.2.1.14.2.2.04.2.2.14.2.3.04.2.3.14.2.4.04.2.5.0
3.2 and prior            
4.0 - 4.1            
4.2.0.0            
4.2.0.1            
4.2.0.2            
4.2.0.3            
4.2.1.0            
4.2.1.1            
4.2.2.0            
4.2.2.1            
4.2.3.0            
4.2.3.1            
4.2.4.0            

Key:

ColorSupported? VDB Downtime Required? 1
 NoN/A
 YesRequired
 YesNot Required
 YesOptional 2
  1. VDB Downtime is caused by a reboot of the Delphix Engine when DelphixOS is modified by an upgrade.
  2. VDB Downtime may be optional for an upgrade when a release contains DelphixOS changes that are also optional. In such a scenario, the DelphixOS changes may be deferred (see documentation on Deferred OS Upgrade).


Tested Browser Configuration Matrix

OS SupportedBrowsers SupportedAdobe Flash/FlexMinimum Memory
Windows XP Professional SP3Internet Explorer 8.x*10.x4GB
Windows XP Professional SP3Firefox, Chrome10.x4GB
Windows Vista SP2Internet Explorer 8.x*, 9.x10.x4GB
Windows 7Internet Explorer 8.x*, 9.x, 10.x, 11.x10.x4GB
Windows 7Firefox, Chrome10.x4GB
Windows 7 x64Internet Explorer 8.x*, 9.x, 10.x, 11.x10.x4GB
Windows 7 x64Firefox, Chrome10.x4GB
Mac OS XFirefox, Chrome9.0.3 (6531.9)4GB

 

* IE8.x support is deprecated, and will be removed in a future Delphix Engine version.

Supported Oracle DBMS Versions and Operating Systems for Source and Target Environments

Source and Target OS and DBMS Compatibility

The source and target must be running the same DBMS/Operating System combination (for example, Oracle 10.2.0.4 on RHEL 5.2) in order to successfully provision a VDB to the target. If the DBMS versions are compatible, the OS version on a target host can be different from the OS version on the source host.

Supported DBMS Versions

  • Oracle 9.2.0.8
  • Oracle 10.2
  • Oracle 11.1
  • Oracle 11.2
  • Oracle 12.1

Oracle 9.2.0.8

The Delphix Engine has limited support for Oracle 9.2.0.8 and cannot link to a database that has a compatibility setting lower than 9.2.0.8.

Oracle 10.2.0.4

The Delphix Engine does not support Oracle 10.2.0.4 databases using Automatic Storage Management (ASM) that do not have the patch set for Oracle Bug 7207932. This bug is fixed in patch set 10.2.0.4.2 onward. 

 

Supported Operating Systems

Operating SystemVersionProcessor Family
Solaris9, 10U5 - 10U11, 11U1, 11U2

SPARC

Solaris10U5 - 10U11, 11U1, 11U2x86_64
Red Hat Enterprise Linux

4.7, 4.8, 4.9
5.3 - 5.11
6.0 - 6.6

x86_64
Oracle Enterprise Linux5.3 -  5.11
6.0 - 6.6
x86_64
Novell SUSE Linux Enterprise Server10, 10SP1, 10SP2, 10SP3
11, 11SP1, 11SP2, 11SP3
x86_64
AIX5.3, 6.1, 7.1Power
HP-UX

11i v2 (11.23)

11i v3 (11.31)

IA64

Delphix supports all 64-bit OS environments for source and target, though 64-bit Linux environments also require that a 32-bit version of glibc installed

Required HP-UX patch for Target Servers

  PHNE_37851 - resolves a known bug in HP-UX NFS client prior to HP-UX 11.31.

Supported SQL Server Versions, Operating Systems, and Backup Software

Supported Versions of Windows OS

  • Windows Server 2003 SP2, 2003 R2

  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Server 2012, 2012 R2

Delphix supports only 64-bit versions of Windows on target hosts and validated-sync-target hosts.

Target hosts and validated-sync-target hosts running Windows Server 2003 SP2 or 2003 R2 must install the hotfix documented in KB 943043.

There are further restrictions on supported Windows and SQL Server versions for SQL Server Failover Cluster target environments. See Adding a SQL Server Failover Cluster Target Environment for details.

Supported Versions of SQL Server

SQL Server Version

Delphix Version

SQL Server 2005 (9.0)Delphix 3.x
SQL Server 2008 (10.0)Delphix 3.x
SQL Server 2008 R2 (10.5)Delphix 3.x
SQL Server 2012 (11.0)Delphix 3.1.2 and beyond
SQL Server 2014 (12.0)Delphix 4.1.3 and beyond

Supported SQL Server Backup Software

The Delphix Engine interacts with source database backups in the following ways:

  • When linking a new source database, the Delphix Engine can use an existing full backup to load the source database data
  • When performing a sync of an existing dSource, the Delphix Engine can use an existing full backup
  • After the dSource is created, the Delphix Engine picks up any new backups that are taken on the source database and applies them to the copy of the source database on the Delphix Engine. This includes:
    • Transaction log backups for databases in Full or Bulk-Logged recovery models
    • Differential and full backups for databases in Simple recovery model

Delphix currently supports the following backup software for source database backups:

  • SQL Server native backups
  • Quest/NetVault LiteSpeed
    • If the source database is backed up with LiteSpeed, the source and the staging environments must have LiteSpeed installed on them. The version of LiteSpeed on the staging environment must be the same or higher than that on the source. Delphix currently supports LiteSpeed v5.0.0.0 and onwards.
  • Red Gate SQL Backup Pro
    • If the source database is backed up with SQL Backup Pro, the source and the staging environments must have SQL Backup Pro installed on them. The version of SQL Backup Pro on the staging environment must be the same as that on the source. Delphix currently supports SQL Backup Pro v7.3 and onwards.

Delphix does not support encrypted backups.


Supported PostgreSQL Versions and Operating Systems

Source and Target OS and DBMS Compatibility

The source and target environments must be running the same DBMS/Operating System combination (for example, PostgreSQL 9.2 on RHEL 6.3) in order to successfully perform linking and provisioning.

Supported DBMS Versions

DBMSVersionProcessor Family
PostgreSQL9.2, 9.3, 9.4x86_64
EnterpriseDB Postgres Plus Advanced Server9.2, 9.3, 9.4x86_64

Supported Operating Systems

Operating SystemVersionProcessor Family
Red Hat Enterprise Linux 5RHEL 5.3, 5.4, 5.5, 5.6, 5.7, 5.8, 5.9, 5.10,5.11x86_64
Red Hat Enterprise Linux 6RHEL 6.0, 6.1, 6.2, 6.3, 6.4, 6.5, 6.6x86_64

Supported SAP ASE Versions and Operating Systems

DBMS VersionsOperating System VersionsProcessor Family
SAP Adaptive Server Enterprise (ASE) 15.0.3, 15.5, 15.7, 16.0Red Hat Enterprise Linux 6.2, 6.3, 6.4x86_64
SAP Adaptive Server Enterprise (ASE) 12.5Red Hat Enterprise Linux 5.xx86_64
SAP Adaptive Server Enterprise (ASE) 12.5, 15.03, 15.5, 15.7, 16.0 Solaris 10x86_64
SAP Adaptive Server Enterprise (ASE) 12.5, 15.03, 15.5, 15.7, 16.0 Solaris 10SPARC
SAP Adaptive Server Enterprise (ASE) 15.7, 16.0AIX 7.1POWER

Source and Target OS and DBMS Compatibility

The source and target must be running the same DBMS version. For example, if the source is running SAP ASE 15.7, then so must the target. Operating System platform must be the same between the source and target, although the operating system version may differ. For example, if the source is running Red Hat Enterprise Linux 6.2 x86_64 then the target could be running Red Hat Enterprise Linux 6.4 x86_64, but not Solaris 10 SPARC.

Licenses and Notices

  • Highstock software products is owned and licensed through Highsoft AS.