• Delphix Support Policies specifically list Major and Minor release coverage. If a minor release is listed as covered, then all patch releases under that minor release are certified.
  • Delphix only supports 64-bit operating systems.

Key:

Color

Supported? 

Yes

Not Applicable

Windows Server


Supported DBMS Version
Supported OS VersionSQL Server 2012SQL Server 2014SQL Server 2016SQL Server 2017SQL Server 2019
Windows Server 2012

Windows Server 2012 R2

Windows Server 2016

Windows Server 2019

Windows Server 2022

Windows Support

Delphix only supports "Windows with Desktop Experience" server Installation.  Windows Core (Windows without Desktop Experience) is NOT included in our general support.

Windows Support

After applying Windows updates or .NET updates for Windows Server 2016 or 2019, servers used to host Delphix VDBs may experience the following symptoms:

  • CPU usage on the Windows target host may increase significantly, possibly reaching 100%.
  • PowerShell may take up to 10 seconds to launch from the command line.

For more information on how to resolve this issue, see KBA6024.

64-bit Windows only

Delphix supports only 64-bit versions of Windows on VDB Target Hosts and Staging Target Hosts. This restriction does not apply to Source Hosts.

Check OS Compatibility

The Windows Server OS versions on the Staging Target Hosts and VDB Target Hosts must be compatible. Please refer to the compatibility matrices below.

SQL Server Failover Clusters

There are additional restrictions on supported Windows and SQL Server versions for SQL Server Failover Cluster target environments.

For details, see Adding a SQL Server Failover Cluster Target Environment.

Supported SQL Versions 

SQL Server Version

Delphix Version

SQL Server 2012 (11.0)Delphix 3.1.2 and beyond
SQL Server 2014 (12.0)Delphix 4.1.3 and beyond
SQL Server 2016 (13.0)Delphix 5.1.4 and beyond
SQL Server 2017 (14.0)Delphix 5.2.3 and beyond
SQL Server 2019 (15.0)Delphix 5.3.7 and beyond

Supported Windows Connector Versions 

You can always download the current Windows connector version from the Delphix Engine from the following locations:

Delphix Dynamic Data Platform versions before 6.0.5.0:

http://<name of your Delphix Engine>/connector/DelphixConnectorInstaller.msi 

Delphix Dynamic Data Platform versions 6.0.5.0 onwards:

http://<name of your Delphix Engine>/connector/DelphixConnectorInstaller.exe

Note

The Delphix Connector and Engine are generally backward-compatible.

Delphix connector version 1.18.0 and beyond is compatible with Delphix Engine 6.0.5.0 and later releases.

Delphix connector version 1.17.0 or earlier is compatible with Delphix Engine 6.0.4.0 and earlier releases.

Checking the Windows Connector Version

After installing the connector, you can perform the following steps to determine the Windows connector version.

  1. Navigate to the Windows Environment.
  2. In the search box on the taskbar, type Add or Remove Programs or launch Start > Control Panel > Programs > Programs and Features.
  3. On the Add or Remove Programs screen, locate Delphix Connector and then click on the software to check the version installed. 

Windows Connector Matrix

The following table details the supported Windows Connector and JRE versions for the corresponding Delphix Dynamic Data Platform versions.

Delphix Dynamic Data Platform VersionWindows Connector VersionJRE Version
4.21.2.01.7.0_71 (4.2.5.1)
4.31.3.01.8.0_40 (4.3.5.1)
5.1.0.0-5.1.4.01.4.01.8.0_40
5.1.5.0-5.1.9.01.5.01.8.0_112
5.2.0.0-5.2.2.01.9.01.8.0_131 (5.2.2.1)
5.2.3.0-5.2.4.01.10.01.8.0_162
5.2.5.0-5.3.3.01.12.01.8.0_202
5.3.4.01.13.01.8.0_202
5.3.5.01.14.01.8.0_202
5.3.6.0-5.3.7.01.15.01.8.0_202
5.3.8.0-6.0.0.01.16.01.8.0_202
6.0.1.0-6.0.4.01.17.0OpenJDK 8u242
6.0.5.0-6.0.8.01.18.0OpenJDK 8u262-b10
6.0.9.0-6.0.10.01.20.0OpenJDK 8u282-b08
6.0.11.01.21.0.0OpenJDK 8u302-b08
6.0.12.01.22.0.0 OpenJDK 8u302-b08
6.0.12.11.22.0.0 OpenJDK 8u302-b08
6.0.13.01.23.0.0 OpenJDK 8u302-b08


The following table details the .Net connector version compatibility for the corresponding Windows Connector versions.

.Net Connector VersionWindows Connector Version
3.51.17.0 and earlier
3.5 and 4.0+1.18.0 and higher

File Checksum / Hashes

The following table provides the MD5 and SHA256 file hash for recent Delphix versions, in the instance that a security policy requires an exception for software installation.

Delphix Dynamic Data Platform VersionConnector VersionMD5 HashSHA256 Hash
6.0.0.01.16.084616c4f86c0d871127feb26b9b8bd52bc2e5e4b26c33d739f7be12f53637979481e1371325e0b5c7645462f6cf5f4f3
6.0.1.01.17.0bb6544dcff3f22d6bf9e20429b1cdb0c

8d914b77d2c5aa0695c3fdbe7d7394e8ae051c091f6f5ee59185cb1d9d157542

6.0.1.11.17.0dd3ea3bedf92a1f8d7e89228315ee31575ed8aa2cf2689916e0b92de6c2aa2fa7660003d62ff07e99978f95dcc9f6abc
6.0.2.01.17.04770f8c1ad46430a1e4b8764ad687ff5a98f1c1f90d5053f62d74c1a74bc27b3b48f68a3e067dce04ce9ab2ccf484241
6.0.2.11.17.097ec3d13db50ad843625b7757c1a23607c2ab497ae4ac27b907611e976d7068ed8eaf54e52b836591c082bbe01079512
6.0.3.01.17.03154c7a5fd7bcb4f0e2c66d328290e6aefb69b2df884705e488d3405a3958c3bb5457142cbfc71990559bb549c2e8c37
6.0.3.11.17.02f73be2cf8ceef97cf519c716237462d7fa7bc269bbc944568231f93ac17ba919b494aa43009967245b75f4abe576a73
6.0.4.01.17.06a4b7f0a5d180438ff199b2b464506cd971b88456574e8e11906b5e6850ea46f012490dcb789a5af73f37d71158ffebf
6.0.4.11.17.0ea9a564d0cae1066cd9607824292fbd7674f9896360a351b314d6aa6e624f9270ef9e3e8d113baddf028581f1ddddec9
6.0.4.21.17.0c5f855c1fa26f5cd3d84d70a94fc048007d71acafd559e15782e7145225734adf5e50356d2f8abe5a52bbd90f3a44cbe
6.0.5.01.18.0a3ac768989a6c1dae41adf945254823671525c31edcf321d2c0220f4edf8932e249e2cd14b261054af1859574dc9e5eb
6.0.6.01.18.0acb09cbd754e9c25d1afa17b35321cd43a51bd3b05148dc3563c5b36d83d44ac725295c23c4b7e9c28f54263058fe2b4
6.0.6.11.18.032202760adb743a62851f8b698a31bf3ac16e8a5c37807c2fa775ecc18f9e0387f5bd9d235c9e8854275c99d5bf865a1
6.0.7.01.18.02fed8da4b986b95a7efb9a9a148239ba2c2a83bad568617bf5dd36b84ad0de22b811f113acac45124ed0effbeb6aef17
6.0.8.01.18.05bf0b950cdcad8c39db60e1a7406d985eae5958878a22b4f4f0456210c031ef9c11d064a05ca6cb85535f0e7dec9c0a1
6.0.8.11.18.0a3ac768989a6c1dae41adf945254823671525c31edcf321d2c0220f4edf8932e249e2cd14b261054af1859574dc9e5eb
6.0.9.01.20.0127af1d95372f84feb373ab4f7b280b2b7c7aaceb2b04aebfbd0ba2521dd15520159d54877b0543567b892ee2584c7ce
6.0.10.01.20.0e8a39a57e5a77d106d8040a4537bd8f07d4501bf5f1cf22a7039e8f7429d4b42c0d11b1360434380b174830f1155646e
6.0.10.11.20.0baf1223b73e626798dd404bd4d18a3c9b827d9213e933fce8389322fe25c8d2e1db57ab66709d236b9a8cd5e254bb89d
6.0.11.01.21.0.0412c4c32c7aefb973c21b573dca66d2a9b689a21249456ddf623042cd2595820531cfbfca0703e713d9795036eef49b7
6.0.12.01.22.0.0dc7a97c46ef9e2d91285dcb0712eaf61db544774ac3eb3235bf90deef3e93962f3955e86bd9f14309ecb0fba9d41dd7f
6.0.12.11.22.0.08cf9e955438c6393031c5596ca0420cd130249658f68eab2a2263deceed6a9de6dd54eead66da68886272f3f40b2f9af
6.0.13.01.23.0.031cc5d3869e4c7f93d38014e5bd40b27de1c2fd4c79dcb7391a51774fba1821456ecc031283db5b497145cce383005f2

SQL Server Editions

For Staging Target Hosts, you can use SQL Server Standard Edition only if the source databases do not use SQL Server Enterprise Edition specific features, such as partitioned tables.

However, it is important for VDB target hosts to use the same edition of SQL Server software as the source database so that all features available in the source are also available in the VDB.

Source Environment Operating System Compatibility

Source environments can be running any supported Windows operating system version. There are no compatibility requirements between the source environment’s operating system and that of the target environments. For more information, see Overview of Setting Up SQL Server Environments.

Staging and Target Environment Operating System Version Compatibility

The operating system version on the target environment that will contain the virtual databases must be equal to or higher than that on the staging target.

Source and Staging Environment SQL Server Version Compatibility

The SQL Server version on the staging environment must be equal to that on the source environment.

Provisioning to Higher SQL Versions When the Source is SQL Server 2005

For SQL Server 2005, direct provisioning to higher SQL Server versions is only supported for provisioning to SQL Server 2012 or higher. You can first provision a VDB to SQL Server 2005 and then upgrade it to a higher version by following the steps outlined in Upgrading SQL Server VDBs.

Supported SQL Server Backup Software

Delphix currently supports the following software for dSource backups:

  • SQL Server native backups - all formats, including but not limited to
    • Striped
    • Compressed
    • Append
    • Overwrite
  • Veritas NetBackup
    • Delphix currently supports NetBackup v7.7.3, v8.0, and v8.1.
    • The version of the NetBackup client on the staging environment must be the same as that on the source.
    • If the dSource is backed up with NetBackup, the source and staging environments must have a NetBackup client installed.
      VDB target environments do not need to have NetBackup installed.
    • Logsync (point-in-time provision) is currently not supported.
    • See Linking a dSource from a NetBackup SQL Server Backup for more NetBackup requirements and additional information about NetBackup.
  • Commvault
    • Delphix currently supports Commvault v11. 
    • The version of Commvault SQL Agent on the staging environment must be the same as that on the source. 
    • If the dSource is backed up with Commvault, the source and staging environment must have Commvault SQL Agent installed.
      VDB target environments do not need to have Commvault SQL Agent installed.
    • Commvault SQL Agent on staging environment must be registered to the CommServe server, which is managing source database backups. 
    • Logsync (point-in-time provision) is currently not supported.
    • See Linking a dSource from a Commvault SQL Server Backup for more Commvault requirements and additional information about Commvault.
  • Quest/NetVault LiteSpeed
    • Delphix currently supports LiteSpeed v5.0.0.0 to v8.9. 
    • The LiteSpeed version on the staging environment must be the same or higher than that on the source.
    • If the dSource is backed up with LiteSpeed, the source and the staging environments must also have LiteSpeed installed.
      VDB target environments do not need to have LiteSpeed installed.
    • On source SQL Server Instance, the dSource user must be granted execute privilege on extended stored procedure master.dbo.xp_sqllightspeed_version.
  • Red Gate SQL Backup Pro
    • Delphix currently supports SQL Backup Pro v7.3 to v7.6 and v10.0.
    • The version of SQL Backup Pro on the staging environment must be the same as that on the source. 
    • On source SQL Server Instance, the dSource database user must be granted execute privilege on extended stored procedure master.dbo.sqbutility.

If the dSource is backed up with SQL Backup Pro, the source and the staging environments must have SQL Backup Pro installed.
VDB target environments do not need to have SQL Backup Pro.

Source and Provisioning Environment SQL Server Compatibility Matrix

When provisioning a VDB, the SQL Server version on the target should be equal to or higher than that on the source.
 


Provisioning Target Environment

SQL Server 2012SQL Server 2014SQL Server 2016SQL Server 2017SQL Server 2019
Source Environment




SQL Server 2012XXXXX
SQL Server 2014
XXXX
SQL Server 2016

XXX
SQL Server 2017


XX
SQL Server 2019



X

Related Topics