Release 5.2.3.1 Changes

Management Server Fixes

Bug Number

DLPX-57411Bug fix to improve quality of upgrade when using a VDB in multiple Self Service data templates.

Release 5.2.3.0 Changes

Management Server Fixes

Bug Number
DLPX-56271Provisioning to environments with no discovered or manually added listeners failed.
DLPX-56539Regex enforcing JDBC strings on upgrade should not be case-sensitive regarding the prefix jdbc:oracle:thin:@.
DLPX-56695System user can be configured as an LDAP user from system setup.
DLPX-56598The User screen UI did not have a scroll bar.
DLPX-56805On a masked VDB configured Clone hooks could not be deleted.
DLPX-56621Updated Java library for the toolkits to the latest stable version.
DLPX-56862Updated version of JRE in Windows Connector 1.0.
DLPX-56885Able to mask VDB from the UI.
DLPX-56912Masking job selected in Configuration tab of the Provision VDB UI was not applied if submitting from that tab.
DLPX-56890Setting 'Data Operator' and 'Reader' privileges via UI failed after upgrade to 5.2.2.0.

DLPX-56856

DLPX-56857

Management service crashed when loading the Dataset Performance screen.
DLPX-56980Disk expand checkboxes disabled despite expandable space.

Masking Fixes

Bug NumberDescription
DLPX-55691Add support for special characters in the database schema name.
DLPX-56069Support special characters in an SFTP connector password.
DLPX-56214Support large numeric values with the secure shuffle algorithm.
DLPX-56099Prevent the secure shuffle algorithm from being used with file or mainframe masking jobs.
DLPX-56231Display a date format input when the date shift algorithm is selected in the Masking Job Wizard.
DLPX-56323Display a date format input when the min/max algorithm is selected in the Masking Job Wizard.
DLPX-56317Add support for setting a min/max algorithm's date format in the Masking v5 API.
DLPX-56359Fix an issue with the secure shuffle algorithm's support for certain Oracle NUMBER datatype sizes.
DLPX-56483Add support for ' (single quote) characters in a rule set's filter (where clause).
DLPX-56469The Jackson library is vulnerable to CVE-2017-15095 prior to version 2.9.0.pr3. While Delphix believes the masking engine is not susceptible to this vulnerability, we have upgrading the version of Jackson used to version 2.9.2.
DLPX-56867Fix an issue that can cause upgrades to fail when the Masking Engine has rule sets with many columns and limited memory.
DLPX-56852Improve the performance of updating and deleting large rule sets.

Delphix OS Fixes

Bug NumberDescription
DLPX-56615This fix allows LDAP users to log into the Delphix Engine's command-line interface (CLI) when challenge-response support authentication (CRA) is enabled.


Release 5.2.2.1 Changes

Management Server Fixes

Bug NumberDescription
DLPX-56373VDB disable/enable fails post-upgrade if mount and umount commands are not in path on staging and/or target machine for environment user.