This topic describes the Oracle Database Management System (DBMS) versions that Delphix supports, as well as the compatible operating systems (OS), for use on target and source environments.

Source and Target OS and DBMS Compatibility

In order to provision a VDB to the target successfully, the source and target must be running the same DBMS/operating system combination – for example, Oracle 10.2.0.4 on RHEL 5.2. If the DBMS versions are compatible, the OS version on the target host can be different from the OS version on the source host.

Supported OS and DBMS Versions

Support applies to corresponding versions of Community Enterprise Operating System (CentOS) / Oracle Linux (OL).

x86/x64 CPU environments support.

Red Hat Enterprise Linux (RHEL) 

Supported DBMS Version

Oracle 10g

Oracle 11gR1

Oracle 11gR2

Oracle 12cR1

Oracle 12cR2

Oracle 18cOracle 19c

Supported OS Version
RHEL 5.5SupportedSupportedSupportedN/AN/AN/AN/A
RHEL 5.6SupportedSupportedSupportedSupportedN/AN/AN/A
RHEL 5.7SupportedSupportedSupportedSupportedN/AN/AN/A
RHEL 5.8SupportedSupportedSupportedSupportedN/AN/AN/A
RHEL 5.9SupportedSupportedSupportedSupportedN/AN/AN/A
RHEL 5.10SupportedSupportedSupportedSupportedN/AN/AN/A
RHEL 5.11SupportedSupportedSupportedSupportedN/AN/AN/A
RHEL 6.0N/AN/ASupportedSupportedN/AN/AN/A
RHEL 6.1N/AN/ASupportedSupportedN/AN/AN/A
RHEL 6.2N/AN/ASupportedSupportedN/AN/AN/A
RHEL 6.3N/AN/ASupportedSupportedN/AN/AN/A
RHEL 6.4N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 6.5N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 6.6N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 6.7N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 6.8N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 6.9N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 6.10N/AN/ASupported in 5.3.1+Supported in 5.3.1+Supported in 5.3.1+Supported in 5.3.1+N/A
RHEL 7.0N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 7.1N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 7.2N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 7.3N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
RHEL 7.4N/AN/ASupportedSupportedSupportedSupported in 5.3.1+Supported in 5.3.5+
RHEL 7.5N/AN/ASupported in 5.3.1+SupportedSupported in 5.3.1+Supported in 5.3.1+Supported in 5.3.5+
RHEL 7.6N/AN/ASupported in 5.3.4+Supported in 5.3.4+Supported in 5.3.4+Supported in 5.3.4+Supported in 5.3.5+


SUSE Linux Enterprise Server (SLES)

Support for SLES 15 requires installing the libncurses.5 library onto the host.


Supported DBMS Version

Oracle 10g

Oracle 11gR1

Oracle 11gR2

Oracle 12cR1

Oracle 12cR2

Oracle 18cOracle 19c


Supported OS Version
SLES 11SupportedSupportedSupportedN/AN/AN/AN/A
SLES 11 SP1SupportedSupportedSupportedN/AN/AN/AN/A
SLES 11 SP2SupportedSupportedSupportedSupportedN/AN/AN/A
SLES 11 SP3SupportedSupportedSupportedSupportedN/AN/AN/A
SLES 11 SP4Not SupportedNot SupportedSupportedSupportedN/AN/AN/A
SLES 12N/AN/ASupportedSupportedN/AN/AN/A
SLES 12 SP1N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
SLES 12 SP2N/AN/ASupportedSupportedSupportedSupported in 5.3.1+N/A
SLES 12 SP3N/AN/ASupported in 5.3.2+Supported in 5.3.2+Supported in 5.3.2+Supported in 5.3.1+Supported in 5.3.5+
SLES 12 SP4N/AN/ASupported in 5.3.4+Supported in 5.3.4+Supported in 5.3.4+Supported in 5.3.4+Supported in 5.3.5+
SLES 15N/AN/ANot SupportedNot SupportedSupported in 5.3.2+Supported in 5.3.2+Not Supported

Solaris SPARC


Supported DBMS Version

Oracle 10g

Oracle 11gR1

Oracle 11gR2

Oracle 12cR1

Oracle 12cR2

Oracle 18c


Supported OS Version

Solaris 10 U9SupportedSupportedSupportedN/AN/AN/A
Solaris 10 U10SupportedSupportedSupportedSupportedN/AN/A
Solaris 10 U11SupportedSupportedSupportedSupportedNot supportedNot supported
Solaris 11N/AN/ASupportedSupportedN/AN/A
Solaris 11 U1N/AN/ASupportedSupportedN/AN/A
Solaris 11 U2N/AN/ASupportedSupportedSupported

Not Supported

Solaris 11 U3N/AN/ANot SupportedSupportedSupported

Not Supported

Solaris 11 U4N/AN/ANot SupportedNot SupportedSupportedNot Supported

Solaris x86 


Supported DBMS Version

Oracle 10g

Oracle 11gR1

Oracle 11gR2

Oracle 12cR1

Oracle 12cR2

Oracle 18c


Supported OS Version
Solaris 10 U9SupportedSupportedSupportedN/AN/AN/A
Solaris 10 U10SupportedSupportedSupportedSupportedN/AN/A
Solaris 10 U11SupportedSupportedSupportedSupportedN/ASupported in 5.3.2+
Solaris 11N/AN/ASupportedSupportedN/AN/A
Solaris 11 U1N/AN/ASupportedSupportedN/AN/A
Solaris 11 U2N/AN/ASupported

Supported

Supported
Supported in 5.3.2+
Solaris 11 U3N/AN/ANot SupportedSupported
Supported
Supported in 5.3.5+
Solaris 11 U4N/AN/ANot SupportedNot SupportedSupported in 5.3.4+Supported in 5.3.5+


Hewlett Packard Unix (HP-UX)

Supported DBMS Version

Oracle 10g


Oracle 11gR1

Oracle 11gR2

Oracle 12cR1

Oracle 12cR2

Oracle 18c



Supported OS Version

HP-UX 11.31

Supported

Supported

Supported

Supported

Supported
Not Supported


Advanced Interactive eXecutive (AIX)

Supported DBMS Version

Oracle 10g


Oracle 11gR1

Oracle 11gR2

Oracle 12cR1

Oracle 12cR2

Oracle 18c



Supported OS Version

AIX 6.1

Supported

Supported

Supported

Supported

Not SupportedNot Supported

AIX 7.1

N/A

N/A

Supported

Supported

SupportedNot Supported

AIX 7.2

N/A

N/A

Supported

Supported

SupportedNot Supported




Oracle 9.2.0.8

The Delphix Engine has limited support for Oracle 9.2.0.8 and cannot link to a database that has a compatibility setting lower than 9.2.0.8.

Delphix features supported with Oracle 9.2.0.8:

FeaturedSourceVDB

SnapSync

YesNo

LogSync

NoNo

Rewind

Not ApplicableNo
V2P (virtual to physical)YesNo
RACNoNo
Standby DatabaseNoNo

Oracle 10.2.0.4

The Delphix Engine does not support Oracle 10.2.0.4 databases using Automatic Storage Management (ASM) that do not have the patch set for Oracle Bug 7207932. This bug is fixed in patch set 10.2.0.4.2 onward. 

Oracle 12.x and 18.x

Delphix supports the same set of features and functionality for Oracle 11gR2, Oracle 12c, and 18c non-multitenant databases.

Delphix does not currently support the Oracle 12c feature of THREADED_EXECUTION being set to TRUE, because this disables OS authentication.

Summary of Delphix features that are unsupported for the Oracle12c and 18c Multi-tenant configuration:

  • Existing Virtual Container Database (vCDB) as target for provisioning an additional vPDB
  • Customize VDB settings/initialization parameters. Includes the following:
    • Customize init.ora database parameter during provisioning
    • Config templates
    • Online redo log size
    • Number of RAC VDB instances
    • Online redo log groups
    • Archive log mode
    • Setting new DBID
    • Customize local listeners
  • Virtual to Physical (V2P) Support
  • For vPDBs in non-virtual CDBs, automatic restart on target server reboot
  • Resumable initial SnapSync
  • Validated Sync
  • Source continuity for dSource upgraded from Oracle 12c non-multitenant to multitenant database
  • Cross-platform provisioning (XPP) to the virtual database
  • Transparent Data Encryption (TDE) support
  • Oracle LiveSources

Required HP-UX patch for Target Servers

  PHNE_37851 – resolves a known bug in HP-UX NFS client prior to HP-UX 11.31.

ExaCC Support

Delphix does not support Oracle Database Exadata Cloud at Customer (ExaCC).