This topic describes the versions of the Windows operating system and SQL Server that Delphix supports.

Supported Versions of Windows OS

The following Windows Server versions are supported as source environments, or as target environments if the listed service packs and hotfixes are in place:


Windows Server Version

Requirements for Staging/Target Hosts
Windows Server 2008
  • Service Pack 2 (SP2) or later is required
  • A recent Monthly Rollup update, including fixes for KB967351 (NTFS)
Windows Server 2008 R2
  • A recent Monthly Rollup update, including fixes for KB967351 (NTFS) and KB2277122 (iSCSI)
Windows Server 2012
Windows Server 2012 R2
Windows Server 2016

 

64-bit Windows only

Delphix supports only 64-bit versions of Windows on VDB Target Hosts and Staging Target Hosts. This restriction does not apply to Source Hosts.

Check OS Compatibility

The Windows Server OS versions on the Staging Target Hosts and VDB Target Hosts must be compatible.

Please refer to the compatibility matrices on this page: Windows Server OS and SQL Server DBMS Compatibility Matrices

SQL Server Failover Clusters

There are additional restrictions on supported Windows and SQL Server versions for SQL Server Failover Cluster target environments.

For details, see Adding a SQL Server Failover Cluster Target Environment.


Supported Versions of SQL Server

SQL Server Version

Delphix Version

SQL Server 2005 (9.0)Delphix 3.x
SQL Server 2008 (10.0)Delphix 3.x
SQL Server 2008 R2 (10.5)Delphix 3.x
SQL Server 2012 (11.0)Delphix 3.1.2 and beyond
SQL Server 2014 (12.0)Delphix 4.1.3 and beyond
SQL Server 2016 (13.0)Delphix 5.1.4 and beyond
SQL Server 2017 (14.0)Delphix 5.2.3 and beyond

SQL Server Editions

For Staging Target Hosts, you can use SQL Server Standard Edition only if the source databases do not use SQL Server Enterprise Edition specific features, such as partitioned tables.

However, it is important for VDB target hosts to use the same edition of SQL Server software as the source database so that all features available in the source are also available in the VDB.

Supported Windows Connector Version

You can always download the current Windows connector version from the Delphix Engine from the following locations:

Delphix Dynamic Data Platform versions before 5.3.9.0:

http://<name of your Delphix Engine>/connector/DelphixConnectorInstaller.msi 

Note

The Delphix Connector and Engine are generally backward-compatible.

Delphix connector version 1.16.0 or earlier is compatible with Delphix Engine 5.3.9.0 and earlier releases.

Checking the Windows Connector Version

After installing the connector, you can perform the following steps to determine the Windows connector version.

  1. Navigate to the Windows Environment.
  2. In the search box on the taskbar, type Add or Remove Programs or launch Start > Control Panel > Programs > Programs and Features.
  3. On the Add or Remove Programs screen, locate Delphix Connector and then click on the software to check the version installed. 

Windows Connector Matrix

The following table details the supported Windows Connector and JRE versions for the corresponding Delphix Dynamic Data Platform versions.

Delphix Dynamic Data Platform VersionWindows Connector VersionJRE Version
4.21.2.01.7.0_71 (4.2.5.1)
4.31.3.01.8.0_40 (4.3.5.1)
5.1.0.0-5.1.4.01.4.01.8.0_40
5.1.5.0-5.1.9.01.5.01.8.0_112
5.2.0.0-5.2.2.01.9.01.8.0_131 (5.2.2.1)
5.2.3.0-5.2.4.01.10.01.8.0_162
5.2.5.0-5.3.3.01.12.01.8.0_202
5.3.4.01.13.01.8.0_202
5.3.5.01.14.01.8.0_202
5.3.6.0-5.3.7.01.15.01.8.0_202
5.3.8.0-5.3.9.01.16.01.8.0_202

The following table details the .Net connector version compatibility for the corresponding Windows Connector versions.

.Net Connector VersionWindows Connector Version
3.51.16.0 and earlier

File Checksum / Hashes

The following table provides the MD5 and SHA256 file hash for recent Delphix versions, in the instance that a security policy requires an exception for software installation.

Connector VersionMD5 HashSHA256 Hash
1.16.041f9d255ceaaac9d47e799456548d50bdf34f016f874fe90ecf62aaf60da669893430cef5e92416c134c8a6b0a0730b3

Supported SQL Server Backup Software

The Delphix Engine interacts with dSource backups in the following ways:
  • When linking a new dSource (creating a dSource), the Delphix Engine can use an existing full backup (preferred) or initiate a Delphix copy-only full backup to load the data from the dSource.
  • When performing a SnapSync of an existing dSource, the Delphix Engine can use an existing full or differential backup.
  • After creating the dSource, the Delphix Engine picks up any new backups that are taken on the dSource and applies them to the dSource. This includes:
    • Transaction log backups for databases in Full or Bulk-Logged recovery models
    • Differential and full backups for databases in Simple recovery model 

Delphix currently supports the following software for dSource backups:

  • SQL Server native backups
  • Quest/NetVault LiteSpeed
    • If the dSource is backed up with LiteSpeed, the source and the staging environments must also have LiteSpeed installed. 

      VDB target environments do not need to have LiteSpeed installed.

    • Delphix currently supports LiteSpeed v5.0.0.0 to v8.9. The version of LiteSpeed on the staging environment must be the same or higher than that on the source.
    • On source SQL Server Instance, the dSource user must be granted execute privilege on extended stored procedure master.dbo.xp_sqllightspeed_version.
  • Red Gate SQL Backup Pro
    • If the dSource is backed up with SQL Backup Pro, the source and the staging environments must have SQL Backup Pro installed on them.

      VDB target environments do not need to have SQL Backup Pro.

    • Delphix currently supports SQL Backup Pro v7.3 to v7.6 and v10.0. The version of SQL Backup Pro on the staging environment must be the same as that on the source. 
  • Veritas NetBackup
    • If the dSource is backed up with NetBackup, the source and staging environments must have NetBackup client installed.

      VDB target environments do not need to have NetBackup installed.

    • Delphix currently supports NetBackup v7.7.3, v8.0, and v8.1. The version of NetBackup client on the staging environment must be the same as that on the source.
    • Logsync (point-in-time provision) is currently not supported.
    • See Linking a dSource from a NetBackup SQL Server Backup for more NetBackup requirements and additional information about NetBackup.
  • Commvault
    • If the dSource is backed up with Commvault, the source and staging environment must have Commvault SQL Agent installed.

      VDB target environments do not need to have Commvault SQL Agent installed.

    • Delphix currently supports Commvault v11. The version of Commvault SQL Agent on the staging environment must be the same as that on the source. 
    • Commvault SQL Agent on staging environment must be registered to the CommServe server which is managing source database backups. 
    • Logsync (point-in-time provision) is currently not supported.
    • See Linking a dSource from a Commvault SQL Server Backup for more Commvault requirements and additional information about Commvault.


In versions 4.3.3.0 and newer, Delphix supports encrypted backups. If you are running an older version of the Delphix Engine (v 4.3.2.x - 3.0), encrypted backups are not supported.

Related Links