This topic outlines the prerequisites for linking an EBS R12.2 instance to the Delphix Engine.

Ensure your EBS R12.2 instance is supported

See Source EBS R12.2 Instance Requirements to ensure you can link your EBS R12.2 instance to the Delphix Engine.

Ensure your EBS 12.2 environments comply with Oracle's documentation

Your environments must comply with Oracle's requirements for installing EBS. These requirements are outlined on Oracle E-Business Suite Release 12 Installation Guidelines (Doc ID 405565.1) found at https://support.oracle.com/. 

Prepare the dbTier for linking

Delphix Engine's Unix Environment Requirements

The dbTier must meet the source requirements outlined in Requirements for Unix Environments. These requirements are generic to all source Unix environments added to the Delphix Engine.

oracle User

The Delphix Engine must have access to an oracle user on the dbTier.

  • This user should be a member of both the EBS dba and oinstall groups.
  • The user should have read permissions on all dbTechStack and database files that will be cloned.

dbTechStack Binary Permissions

Verify that the oracle user described above has read permissions at the group level for:

  • $ORACLE_HOME/bin/nmb
  • $ORACLE_HOME/bin/nmhs
  • $ORACLE_HOME/bin/nmo

Clean Up Before Provisioning Option

If you plan to utilize the Cleanup Before Provision option available during dbTechStack provisioning, the Delphix Engine requires the Database Oracle Home to be patched with Oracle Universal Installer (OUI) version 10.2 or above. You can read more about the Clean Up Provisioning option in Provisioning a Virtual EBS R12.2 Instance.

Note that provisioning is still possible without this option specified, but you will need to manage the target dbTier's Oracle Inventory manually to ensure that conflicting entries do not cause provisions to fail.

The Delphix Engine's Oracle Database Requirements

The dbTier must meet the source requirements outlined in Oracle Support and Requirements. These requirements are generic to all Unix environments containing an Oracle database to be linked.

Prepare the appsTier for Linking

Delphix Engine's Unix Environment Requirements

The appsTier must meet the source requirements outlined in Requirements for Unix Environments. These requirements are generic to all source Unix environments added to the Delphix Engine.

applmgr User

The Delphix Engine must have access to an applmgr user on the appsTier.

  • This user should be a member of the EBS oinstall group.
  • The user should have read permissions on all appsTier files to be cloned.

Clean Up Before Provisioning Option

If you plan to utilize the Cleanup Before Provision option available during appsTier provisioning, the Delphix Engine requires the Tools Oracle Home to be patched with Oracle Universal Installer (OUI) version 10.2 or above. You can read more about this provisioning option in Provisioning a Virtual EBS R12.2 Instance.

Note that provisioning is still possible without this option specified, but you will need to manage the target appTier's Oracle Inventory manually to ensure that conflicting entries do not cause provisions to fail.

Related Topics