New Features

EBS Plugin version 3.0.0 aims to support Oracle 19c MT architecture. Moreover, a new field has been added on the provisioning UI. This will provide the flexibility to the end-user to provide the maximum time allowed to virtualize the application tier.

Plugin Installation

Plugins to support EBS virtualization are not automatically included in the Virtualization Engine deployment and can be installed by the end-user after uploading the plugin through the Manage > Plugin screen.

Migration and Compatibility

Supported Versions

Oracle SI dbTechStack and Database

EBS 12.2

  • Oracle11gR2 v11.2.0.4 (Minimum DB version supported 11.2.0.4)

  • Oracle12cR1 v12.1.0.2 (Minimum DB version supported 12.1.0.2)

  • Oracle19c MT v19.3.0.0 (Minimum DB version supported 19.3.0.0)

Oracle EBS appsTier

  • Single-node appsTier

  • Multi-node appsTier with shared APPL_TOP

The Delphix Engine does not provide support for provisioning a multi-node appsTier where the APPL_TOP is not shared between nodes.

 Supported Operating Systems

  • Linux – SLES 9, 10, 11; RHEL 5, 6, 7, OL 5, 6

  • Solaris – SPARC 9, 10, 11

Plugin/Delphix Engine Compatibility

The plugin should be installed on compatible Delphix Engines per the table below. For plugin/engine compatibility of all the released plugin versions, see EBS Matrix.

For EBS 12.2 customers:

Delphix Engine

EBS_3.0.0
5.3.0.0No
5.3.1.0No
5.3.2.0No
5.3.3.0No
5.3.4.0No
5.3.5.0No
5.3.6.0No
5.3.7.0No
5.3.8.0-5.3.8.1No
5.3.9.0No

6.0.0.0

No

6.0.1.0

No

6.0.2.0

No

6.0.3.0

No
6.0.4.0No
6.0.5.0No
6.0.6.0No
6.0.7.0No
6.0.8.0No
6.0.9.0Yes
6.0.10.0Yes

Plugin Upgrade Path

Path A - New plugin installation for EBS customers:

  • Upload 3.0.0 plugin for EBS 12.2 customers

Path B - Existing EBS customers with different plugin version:

For EBS 12.2 customers: 

Your Version

Recommended Upgrade Path to 3.0.0

1.0.0

Upgrade to 1.1.0 and follow the upgrade path below.

1.1.0

Upgrade to 1.2.0 and follow the upgrade path below.

1.2.0

Upgrade to 1.3.0 and follow the upgrade path below.

1.3.0

1.3.1

Upgrade to 1.4.0 and follow the upgrade path below.

1.4.0

Upgrade to 1.5.0 and follow the upgrade path below.

1.5.0

Upgrade to 1.6.0 and follow the upgrade path below.

1.6.0

Upgrade to 1.7.0 and follow the upgrade path below.

1.7.0Upgrade to 1.8.0, 1.8.1, 1.8.2, 1.8.3, or 1.8.4 and follow the upgrade path below.

1.8.0

1.8.1

1.8.2

1.8.3

1.8.4

Upgrade to 2.0.0 or 2.0.1, and follow the upgrade path below.

2.0.0

2.0.1 

Upgrade to 3.0.0, the latest plugin version.


Example
: Upgrade path for EBS 12.2 customer with existing Plugin version 1.1.0 who wants to upgrade to 3.0.0 Plugin version :  1.1.0 → 1.2.0 → 1.3.0 → 1.4.0 → 1.5.0 → 1.6.0 → 1.7.0 → 1.8.0 or 1.8.1, 1.8.2, 1.8.3. or 1.8.4 → 2.0.0 or 2.0.1 → 3.0.0.

  • Customers should skip a minor Plugin 1.3.1 and 1.8.1/1.8.2/1.8.3/1.8.4 version upgrade.
  • If EBS 12.2 customers are on Plugin version 1.3.1, the plugin upgrade path will be : 1.3.1 → 1.4.0 → 1.5.0 → 1.6.0 → 1.7.0 → 1.8.0 or 1.8.1, 1.8.2, 1.8.3. or 1.8.4 → 2.0.0 or 2.0.1 → 3.0.0 .

Key points:

  • Customers can skip a patch plugin release upgrade if they intend to upgrade their plugin to a higher version. The Delphix Engine simply ignores patch versions when handling plugin upgrade logic. It only validates the major/minor plugin version during the plugin upgrade.

Unsupported EBS Versions and Features

  • SSL enabled Environment

  • V2P

Known Issues

Key

Summary

EBS-836"ebs_<PDB_SID>" listener services are getting disappeared on VDB stop/start. As a workaround, a new configure clone hook has been added.

Fixed Issues

EBS plugin version 3.0.0 contains the following bug fixes.

Key

Summary

EBS-767EBS appsTier linking failed while identifying Delta patch level information from low-privilege OS user
EBS-779Continued timeouts - toolkit.ebs122-app-1-8-2.errorTimeout {admanagedsrvctl}
EBS-787Toolkit should perform prior dependency/pre-requisite check in target host before starting to provision dBtechStack and Appstier
EBS-788Error not being shown to the customer
EBS-798GUI shows vfiles ORACLE_HOME as stopped however it is not
EBS-778Expect timeout set to 8 hours which is too short
EBS-798GUI shows vfiles ORACLE_HOME as stopped however it is not
EBS-816EBS 12.2 disable Appstier vdb failed with Delphix cannot stop all processes under /u01/oracle/VIS on host