This Db2 Plugin version includes some bug fixes listed at the end of this section.

Migration and Compatibility

Supported Db2 Database Editions

  1. Enterprise Server Edition
  2. Advanced Enterprise Server Edition
  3. Advanced Edition
  4. Standard Edition
  5. For the supported Db2 versions, Delphix supports the corresponding Db2 Developer edition with Db2 plugin support
  • Delphix Support Policies specifically list Major and Minor release coverage. If a minor release is listed as covered, then all patch releases under that minor release are certified.
  • Db2 versions below 10.5 i.e (10.1, 9.8) are NOT supported by the plugin.
  • Db2 supports only 64-bit OS

Key:

Color

Supported? 

Yes
(error)No

Red Hat Enterprise Linux (RHEL) 

Support for RHEL 8.x requires installing the libncurses.5 library onto the host. Please reference KBA 5622  for actionable steps.

Db2 plugin support for below mentioned OS and Db2 versions


Supported DBMS Version
Supported OS Version10.511.111.5
RHEL 6.9

(error)
RHEL 7.0

(error)
RHEL 7.1

(error)
RHEL 7.2

(error)
RHEL 7.3

(error)
RHEL 7.4

(error)
RHEL 7.5

(error)
RHEL 7.6

(error)
RHEL 7.7(error)

(error)
RHEL 7.8(error)

6.0.5+

RHEL 8.2(error)(error)

Advanced Interactive eXecutive (AIX)

Db2 plugin support for below mentioned OS and Db2 versions


Supported DBMS Version
Supported OS Version10.511.111.5
AIX 7.1

AIX 7.2

Plugin/Delphix Engine Compatibility

Plugins should be installed on compatible Delphix Engines per the table below:

The plugin versions starting 2.1.0 till 2.7.3 are on extended support. Please contact Delphix Support for any queries.


Plugin Version
Delphix Engine3.0.03.0.13.0.23.1.03.1.14.0.04.0.14.1.04.1.14.1.24.1.34.2.0
6.0.0.x

(error)(error)(error)(error)(error)(error)(error)
6.0.1.x

(error)(error)(error)(error)(error)(error)(error)
6.0.2.x

(error)(error)(error)(error)(error)(error)(error)
6.0.3.x

(error)(error)(error)(error)(error)(error)(error)
6.0.4.x

(error)(error)(error)(error)(error)(error)(error)
6.0.5.x

(error)(error)(error)(error)(error)(error)(error)
6.0.6.x

(error)(error)(error)(error)(error)(error)(error)
6.0.7.x

(error)(error)(error)(error)(error)(error)(error)
6.0.8.x

(error)(error)(error)
6.0.9.x

(error)(error)(error)
6.0.10.x

(error)(error)(error)
6.0.11.x

(error)(error)(error)
6.0.12.x

6.0.13.x



Plugin Upgrade Path

Use the table below to determine the most efficient upgrade path from your current version to the latest version of the Db2 Plugin.

Your Version

Recommended upgrade path to Db2 4.1.3

3.0.0

3.0.1

3.0.2

Upgrade to 3.1.0, and follow the path below

3.1.0

3.1.1

Upgrade to 4.0.0 or 4.0.1, and follow the path below

4.0.0

4.0.1

Upgrade directly to 4.1.0, 4.1.1, 4.1.2, or 4.1.3

Fixed Issues

Ticket Number

Summary

DB2-1812CLI operations during snapsync may fail if commands return error messages in a different locale
DB2-1856VDB provision fails with an issue during db2relocatedb
DB2-1875VDB behavior when we provision them using the first snapshot vs the latter ones
DB2-1921 Fix permissions for “/toolkit_dir/DB2” along with mnts/ and logs
DB2-1904Staging push vSDK: snapsync operation on dSource fails with TypeError: unhashable type: ‘SnapshotDefinitionDataPaths’