New Features

EBS Plugin version 1.8.2 introduces a new feature where the user will not need to specify the source apps schema password in EBS DB hooks provision wizard. This password can now be pulled from a text file present on the target DB host which will be created automatically during DBTechStack provisioning.

Plugin Installation

Plugins to support EBS virtualization are not automatically included in the Virtualization Engine deployment and can be installed by the end-user after uploading the plugin through the Manage > Plugin screen.

Migration and Compatibility

Supported Versions

Oracle SI dbTechStack and Database

EBS 12.2

  • Oracle11gR2 (Minimum DB version supported 11.2.0.4)

  • Oracle12cR1 (Minimum DB version supported 12.1.0.2)

Oracle does not yet support the multi-tenant option for E-Business Suites, so Delphix cannot support this either.

Oracle EBS appsTier

  • Single-node appsTier

  • Multi-node appsTier with shared APPL_TOP

The Delphix Engine does not provide support for provisioning a multi-node appsTier where the APPL_TOP is not shared between nodes.

 Supported Operating Systems

Plugin/Delphix Engine Compatibility

The Plugin should be installed on compatible Delphix Engines per the table below. For plugin/engine compatibility of all the released plugin versions, see EBS Matrix.

For EBS 12.2 customers:

Delphix Engine

EBS_1.8.2
5.3.0.0No
5.3.1.0Yes
5.3.2.0Yes
5.3.3.0Yes
5.3.4.0Yes
5.3.5.0Yes
5.3.6.0Yes
5.3.7.0Yes
5.3.8.0-5.3.8.1Yes
5.3.9.0Yes

6.0.0.0

Yes

6.0.1.0

Yes

6.0.2.0

Yes

6.0.3.0

Yes
6.0.4.0Yes
6.0.5.0Yes
6.0.6.0Yes
6.0.7.0Yes
6.0.8.0Yes

Plugin Upgrade Path

Path A - New plugin installation for EBS customers:

  • Upload 1.8.2 plugin for EBS 12.2 customers

Path B - Existing EBS customers with different plugin version:

For EBS 12.2 customers: 

Your Version

Recommended Upgrade Path to 1.8.2

1.0.0

Upgrade to 1.1.0 and follow the upgrade path below.

1.1.0

Upgrade to 1.2.0 and follow the upgrade path below.

1.2.0

Upgrade to 1.3.0 and follow the upgrade path below.

1.3.0

1.3.1

Upgrade to 1.4.0 and follow the upgrade path below.

1.4.0

Upgrade to 1.5.0 and follow the upgrade path below.

1.5.0

Upgrade to 1.6.0 and follow the upgrade path below.

1.6.0

Upgrade to 1.7.0 and follow the upgrade path below.

1.7.0Upgrade to 1.8.0, 1.8.1, or 1.8.2 and follow the upgrade path below.


Example : Upgrade path for EBS 12.2 customer with existing Plugin version 1.1.0 who wants to upgrade to 1.8.1 Plugin version :  1.1.0 → 1.2.0 → 1.3.0 → 1.4.0 → 1.5.0 → 1.6.0 → 1.7.0 → 1.8.0 or 1.8.1 or 1.8.2

  • Customers should skip a minor Plugin 1.3.1 version upgrade.
  • If EBS 12.2 customers are on Plugin version 1.3.1, the plugin upgrade path will be : 1.3.1 → 1.4.0 → 1.5.0 → 1.6.0 → 1.7.0 → 1.8.0 or 1.8.1 or 1.8.2

Key points:

  • Plugin 1.8.2 is a patch release that will support EBS-597 Delphix Hooks Password-Storing Apps password to file for EBS appsTier.
  • Customers can skip a patch plugin release upgrade if they intend to upgrade their plugin to a higher version. The Delphix Engine simply ignores patch versions when handling plugin upgrade logic. It only validates the major/minor plugin version during the plugin upgrade.

Unsupported EBS Versions and Features

  • Sudo Privilege Plugin for EBS 12.2 release

  • Support SSL enabled Environment

  • V2P

  • BYOOJ

Fixed Issues

EBS plugin version 1.8.2 contains the following features and bug fixes:

Key

Summary

EBS_566

Display port pool number in the error toolkit.ebs122-app-1-7-0.portPoolNotFreeError.

EBS-597

Delphix Hooks Password-Storing Apps password to file for EBS appsTier

Known Issues

KeySummary
EBS-692

EBS link operation fails when source EBS environment is linked with BYOOJ

DLPX-69617OperationRunnerImpl incorrectly assumes toolkit JDK always exists