6.0.x Upgrade Matrix

This section lists all the Delphix Engine versions that a user can upgrade to the required or the latest version. 

Self-service upgrades to the Delphix Engine 6.0.* from 5.3.* are not supported. 6.0.6.1 is the last version that can be directly upgraded to, from 5.3.6.0-5.3.9.0. 

Starting with 6.0.10.0, the policy of supporting direct upgrades from software released in the last 12 months will be enforced. Only 6.0.4.0 and above can upgrade directly to 6.0.10.0. If 6.0 engines exist that are older than 6.0.4.0, they need to be upgraded to 6.0.7.0 first.


Please refer to the documentation on How to Upgrade or check with Delphix Support to perform the upgrade.


Upgrade To
Upgrade From6.0.0.06.0.1.06.0.1.16.0.2.06.0.2.16.0.3.06.0.3.16.0.4.06.0.4.16.0.4.26.0.5.06.0.6.06.0.6.16.0.7.06.0.8.06.0.8.16.0.9.06.0.10.06.0.10.16.0.11.06.0.12.06.0.13.06.0.13.1Upgrade
From
5.3.5.0
and prior
(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)5.3.5.0
and prior

5.3.6.0

(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

5.3.6.0

5.3.7.0
(error)

(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)5.3.7.0
5.3.7.1(error)

(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)5.3.7.1
5.3.8.0(error)

(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)5.3.8.0
5.3.8.1(error)

(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)5.3.8.1
5.3.9.0(error)(error)(error)

(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)5.3.9.0
6.0.0.0(error)

(error)(error)(error)(error)(error)(error)6.0.0.0
6.0.1.0(error)(error)

(error)(error)(error)(error)(error)(error)6.0.1.0
6.0.1.1(error)(error)(error)

(error)(error)(error)(error)(error)(error)6.0.1.1
6.0.2.0(error)(error)(error)(error)

(error)(error)(error)(error)(error)(error)6.0.2.0
6.0.2.1(error)(error)(error)(error)(error)

(error)(error)(error)(error)(error)(error)6.0.2.1
6.0.3.0(error)(error)(error)(error)(error)(error)

(error)(error)(error)(error)(error)(error)6.0.3.0
6.0.3.1(error)(error)(error)(error)(error)(error)(error)

(error)(error)(error)(error)(error)(error)6.0.3.1
6.0.4.0(error)(error)(error)(error)(error)(error)(error)(error)

(error)(error)(error)(error)6.0.4.0
6.0.4.1(error)(error)(error)(error)(error)(error)(error)(error)(error)

(error)(error)(error)(error)6.0.4.1
6.0.4.2(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

(error)(error)(error)(error)6.0.4.2
6.0.5.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

(error)

(error)(error)6.0.5.0
6.0.6.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

(error)(error)6.0.6.0
6.0.6.1(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

(error)

(error)6.0.6.1
6.0.7.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.7.0
6.0.8.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.8.0
6.0.8.1(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.8.1
6.0.9.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.9.0
6.0.10.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.10.0
6.0.10.1(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.10.1
6.0.11.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.11.0
6.0.12.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

6.0.12.0
6.0.13.0(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

(error)

6.0.13.0
6.0.13.1(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)(error)

(error)

(error)6.0.13.1
Upgrade
From
6.0.0.06.0.1.06.0.1.16.0.2.06.0.2.16.0.3.06.0.3.16.0.4.06.0.4.16.0.4.26.0.5.06.0.6.06.0.6.16.0.7.06.0.8.06.0.8.16.0.9.06.0.10.06.0.10.16.0.11.06.0.12.06.0.13.06.0.13.1Upgrade
From

Upgrade To

Key:

ColorSupported? VDB Downtime Required? 1
(error)NoN/A

YesRequired

YesOptional 2
  1. VDB Downtime is caused by a reboot of the Delphix Engine when DelphixOS is modified by an upgrade.
  2. VDB Downtime may be optional for an upgrade when a release contains DelphixOS changes that are also optional.