Welcome to the latest release of the Delphix Engine database virtualization system.

New Features

PostgreSQL Plugin version 1.4.0 contains the following certifications :

Operating System - RHEL/CentOS 7.8 version Support with PostgreSQL 12.x.

Plugin Installation

Plugins to support PostgreSQL virtualization are not automatically included in the Virtualization Engine deployment and are installed by Delphix Professional Services or Technical Support. A Support case can be opened requesting installation by following this link.

Migration and Compatibility

Supported Versions

PostgreSQL Standard Versions:

  • PostgreSQL 9.4.x
  • PostgreSQL 9.5.x
  • PostgreSQL 9.6.x
  • PostgreSQL 10.x
  • PostgreSQL 11.x
  • PostgreSQL 12.x

PostgreSQL EDB Versions:

  • PostgreSQL 9.4.x
  • PostgreSQL 9.5.x
  • PostgreSQL 9.6.x
  • PostgreSQL 10.x
  • PostgreSQL 11.x
  • PostgreSQL 12.x

Supported Operating Systems

RHEL/CentOS/SLES - PostgreSQL Open Source & EDB


Supported DBMS Version

PostgreSQL

9.4.x (Open Source & EDB)

PostgreSQL

9.5.x (Open Source & EDB)

PostgreSQL

9.6.x (Open Source & EDB)

PostgreSQL

10.x (Open Source & EDB)

PostgreSQL

11.x (Open Source & EDB)

PostgreSQL

12.x (Open Source & EDB)


Supported OS Version
RHEL/CentOS 7.3SupportedSupportedSupportedSupportedSupportedSupported
RHEL/CentOS 7.4SupportedSupportedSupportedSupportedSupportedSupported
RHEL/CentOS 7.5SupportedSupportedSupportedSupportedSupportedSupported
RHEL/CentOS 7.6SupportedSupportedSupportedSupportedSupportedSupported
SLES 11SupportedNot SupportedNot SupportedNot SupportedNot SupportedNot Supported
SLES 12SupportedSupportedSupportedSupportedSupportedNot Supported

where x is the minor version of the PostgreSQL Database.

Plugin/Delphix Engine Compatibility

Plugins should be installed on compatible Delphix Engines per the table below:

Delphix Engine

PostgreSQL 1.0.1

PostgreSQL 1.0.2

PostgreSQL 1.1.0

PostgreSQL 1.2.0

PostgreSQL 1.3.0

PostgreSQL 1.3.1

PostgreSQL 1.3.2PostgreSQL 1.4.0
6.0.0.xNoNoYesYesYesYesYesYes
6.0.1.xNoNoYesYesYesYesYesYes
6.0.2.xNoNoYesYesYesYesYesYes
6.0.3.xNoNoYesYesYesYesYesYes
6.0.4.xNoNoYesYesYesYesYesYes


Plugin Upgrade Path

Path A - New Plugin installation for PostgreSQL customers:

  • Upload 1.4.0 Plugin for PostgreSQL 9.4.x, 9.5.x, 9.6.x,10.x, 11.x and 12.x customers

Path B - Existing PostgreSQL customers with different Plugin version:

Your Version

Recommended Upgrade Path to 1.4.0

1.0.1

1.0.2

Upgrade to 1.1.0 and follow the upgrade path below.

1.1.0

Upgrade to 1.2.0 and follow the upgrade path below.

1.2.0

Upgrade to 1.3.0 and follow the upgrade path below.

1.3.0

Upgrade to 1.4.0, the latest plugin for PostgreSQL.


For PostgreSQL customers with Plugin version 1.0.1 or 1.0.2 interested in External Backups feature:

Plugin upgrade path: 1.0.1 → 1.1.0 → 1.2.0 → 1.3.0 → 1.4.0 

Plugin upgrade path 1.0.2 → 1.1.0 → 1.2.0 → 1.3.0 → 1.4.0 


For PostgreSQL customers with Plugin version 1.1.0

Plugin upgrade path: 1.1.0 → 1.2.0 → 1.3.0 → 1.4.0 


For PostgreSQL customer with Plugin version 1.2.0

Plugin upgrade path: 1.2.0 → 1.3.0 → 1.4.0


Upgrading Existing Objects

In order to upgrade the existing objects with 1.1.0 (i.e 1.0.1 → 1.1.0 or 1.0.2 → 1.1.0), just after the upgrade, it is mandatory to update below two parameters of dSource using "custom Configuration" option on the UI :

  • Source IP Address
  • Source Port

A critical fault will show up on dSource just after the upgrade. It is because the engine is not able to find the source config from which dSource was created. As we have moved to manual discovery in this release, we need to mark this fault as resolve on the status tab of dSource.

Unsupported PostgreSQL Versions and Features

PostgreSQL versions below 9.4 i.e 9.2, 9.3  (including the minor versions) are not supported.

Unlogged Tables: All the tables which are not logged (unlogged) will not be supported by the Plugin.

Point In Time recovery: Currently, the Plugin doesn’t support Point in Time recovery of PostgreSQL database